TWC Today/TWC Classics Forums

WeatherScan Local Emulator Project => Latest Release Information => Topic started by: cc17926 on January 27, 2009, 05:52:03 AM

Title: Emulator Release - January 2009
Post by: cc17926 on January 27, 2009, 05:52:03 AM
Sorry for the month delay on the promised release. I have been busy with work and other things to release the program in a timely manner, however since there is a great deal of weather out there today, i figure "putting it all together" now would be the most perfect time. There have been a great deal of changes since the last time any of the members have used the emulator, some of these are the following:
-You may re-ordering packages used, with this, you will only need to configure what you are going to use, instead of all objects! The "Up Next..." pages look cleaner because the renderer will dynamically make the frames used.
-Extended play doppler radars, the emulator will collect through continual usage a loop of 24 frames (2 hours). At first start, the emulator begins at 6 frames (half hour) and adds frames as its left running.
-Traffic data will be downloaded by the config server when the emulator is running. If the emulator is not being used for over an hour, traffic data will not be downloaded by the config server, and the emulator will display a "Temporarly Unavailable for 15 minutes" message.
-Semi-Self Provisioning, if you have a login to the config server, that is all you need to download the emulator and recieve the key needed to run the emulator. The key will be encoded when you run the emulator for the first time, or if the past key expired, by selecting "Get My Key" from the emulator's registration panel.

Three Major notes about this release:
1. I have no idea how to clear up this Windows Vista bug with a new installation, you MUST run the program, and "Set Affiliate" program as Administrator (by right-clicking). If anyone knows a way around this or a suggestion, drop that in here or shoot me a message.
2. You MUST uninstall the previous release of the emulator before installing this one, so make sure you save your affilate logo that you enjoy using!
3. If you have previously had the emulator installed before, you must follow these steps

Please check one thing, verify the emulator is running from C:\wsxl\wsxl.exe
if it is infact running from that location, goto start->run and plugin:
C:\wsxl\wsxl.exe unregister
a box will appear, requesting you to press [1] [2] [3] [ OK ]
then try the emulator again like normal.


How to enjoy this release:
1. Make your Package changes on the config server: http://copper.yi.org:21863 (http://copper.yi.org:21863)
2. Make any additional changes, then build your configuration. (Link at the bottom of ' Review Cfg'n' page).
3. Download the emulator from the 'Download and Keys' page.
4. Set your Affilate ID (this is your login to the config server).
5. Run the emulator.

Final note:
If you recieve the Error box complaining about an expired key, select the "No" option to revert to the original default configuration. From there, you can "Get My Key".

If you do not have a login to the config server and would like to use this emulator, please contact Martin or me, and we will help you out!
Title: Re: Emulator Release - January 2009
Post by: Stephen on January 27, 2009, 06:44:10 AM
Awesome! Can't wait to try it out! :biggrin:

BTW, could one of you PM me my log-in information? I forgot it since last release.
Title: Re: Emulator Release - January 2009
Post by: iPod on January 27, 2009, 11:12:39 AM
It's a good thing I'm having a snow day today!
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 27, 2009, 12:33:53 PM
It's a good thing I'm having a snow day today!
Hopefully I'll have one tomorrow. :)
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 27, 2009, 02:00:30 PM
When I go to the Weatherscan folder in my program files to edit the logo, the folder seems to be empty. :unsure:

Also, I have Newark set as one of my local cities and it hasn't been reporting current weather. For the record, the sky conditions according to NWS are mostly cloudy right now (as of 1:51 PM ET).
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 27, 2009, 02:22:34 PM
Now Newark is showing weather conditions, but Dover and McGuire AFB which are reporting Mostly Cloudy. It seems that the emulator doesn't recognize this weather condition. Could this be looked into?
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 27, 2009, 02:41:58 PM
Sometimes the emulator will run into a condition it doesnt know what icon or name to give so it gives you the NA icon with the raw condition. ex. Snw Shw

Ill set up a topic in the near future where people can report those issues.
Title: Re: Emulator Release - January 2009
Post by: cc17926 on January 27, 2009, 03:09:38 PM
When I go to the Weatherscan folder in my program files to edit the logo, the folder seems to be empty. :unsure:

the program folder has been changed to X:\wsxl .. where X: is your system drive letter. it has been moved from the depths of the "Program Files" directory because of issues relating to the alert add-on working properly with the 3rd party software. there will be more on the alert add-on soon.
Title: Re: Emulator Release - January 2009
Post by: Al on January 27, 2009, 03:29:51 PM
i know its not a big deal, but i just thought you should know about the typos in the installation process:

Title: Re: Emulator Release - January 2009
Post by: iPod on January 27, 2009, 03:31:28 PM
lol
Title: Re: Emulator Release - January 2009
Post by: Stephen on January 27, 2009, 05:20:25 PM
i know its not a big deal, but i just thought you should know about the typos in the installation process:
The buttons appeared fine for me... :unsure:
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 27, 2009, 06:03:16 PM
I did not see that as well.
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 27, 2009, 06:13:28 PM
Yah, I didn't see those either. The letters must be cut off on the buttons on the theme you're using.
Title: Re: Emulator Release - January 2009
Post by: shadyjay on January 27, 2009, 08:15:15 PM
am i missing something?  i don't see the download link for the new version of the emulator.

Title: Re: Emulator Release - January 2009
Post by: Mike M on January 27, 2009, 09:47:19 PM
am i missing something?  i don't see the download link for the new version of the emulator.
On the configuration website click on "Download and Keys" on the left panel then click "Main emulator release." That's the download link.
Title: Re: Emulator Release - January 2009
Post by: shadyjay on January 27, 2009, 09:50:34 PM
On that web site, it says under "Main Cfg'n" .... "affiliate disabled - please note, Cfg'n server is being updated".
No download link. 
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 28, 2009, 12:24:18 AM
Try clearing your history and refreshing
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 28, 2009, 07:04:57 AM
I want to say that I'm trilled by the improvements you've made to the emulator, especially with the radars. Excellent work! I'm hooked on this emulator now!
Title: Re: Emulator Release - January 2009
Post by: cc17926 on January 28, 2009, 07:56:45 AM
On that web site, it says under "Main Cfg'n" .... "affiliate disabled - please note, Cfg'n server is being updated".
No download link.

Your account was disabled for one of many reasons, however it is enabled again.

I want to say that I'm trilled by the improvements you've made to the emulator, especially with the radars. Excellent work! I'm hooked on this emulator now!

I am glad to hear that you are happy with the progress to this point, although its taken awhile, but i am sure it was worth the wait! ;)
Title: Re: Emulator Release - January 2009
Post by: shadyjay on January 28, 2009, 10:54:23 AM
Okay, was able to download the new setup file, installed it, and got my new key.  Then I realized I had to do the "unregister 1-2-3-OK" command, now when I go to run the emulator, it requests a key.  I click GET MY KEY, and it says a key was already assigned to me.  I copy the key, then enter it on the next screen, and it says my key is not valid.  Did I unregister my key? 
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 28, 2009, 11:48:16 AM
Okay, was able to download the new setup file, installed it, and got my new key.  Then I realized I had to do the "unregister 1-2-3-OK" command, now when I go to run the emulator, it requests a key.  I click GET MY KEY, and it says a key was already assigned to me.  I copy the key, then enter it on the next screen, and it says my key is not valid.  Did I unregister my key?
Your copying the key you see in CINE right? This is all on the same computer correct?
Title: Re: Emulator Release - January 2009
Post by: cc17926 on January 28, 2009, 12:09:46 PM
Okay, was able to download the new setup file, installed it, and got my new key.  Then I realized I had to do the "unregister 1-2-3-OK" command, now when I go to run the emulator, it requests a key.  I click GET MY KEY, and it says a key was already assigned to me.  I copy the key, then enter it on the next screen, and it says my key is not valid.  Did I unregister my key?

i released the current key that the config server has on record for you, try this again.
Title: Re: Emulator Release - January 2009
Post by: shadyjay on January 28, 2009, 12:44:02 PM
Got it working.... thanks for correcting my issues!

 :clap:
Title: Re: Emulator Release - January 2009
Post by: Mike M on January 29, 2009, 02:32:04 PM
Do you plan on implementing additional segments in the near future? I think Airport and Travel Outlook would be useful segments. :yes: I know for sure all four maps on the travel outlook segment are available on weather.com (travel weather, foggy travel, windy travel, thunderstorm forecast). Not too sure where you could get the airport delays. TWC has the information on the website but there might be a more accurate place you could get it from. I hope I'm not trying to push you, I'm just giving suggestions.
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 29, 2009, 03:07:47 PM
Thats one of the great things about this project. There is so much  that you can add! ;)
Title: Re: Emulator Release - January 2009
Post by: twcfan68 on January 29, 2009, 06:26:40 PM
The emulator is awesome! Wow. I do have one question. Does the emulator report fair conditions? It's been Sunny and Partly Cloudy all day, but not fair, even though both the Hirad and METAR had fair for my location at one point.
Title: Re: Emulator Release - January 2009
Post by: Zach on January 29, 2009, 06:32:57 PM
I don't think the emulator uses HiRAD. :no:
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 29, 2009, 07:18:27 PM
The emulator is awesome! Wow. I do have one question. Does the emulator report fair conditions? It's been Sunny and Partly Cloudy all day, but not fair, even though both the Hirad and METAR had fair for my location at one point.
It does indeed show fair. Oddly enough fair is used both day and night so you may get a sunny icon at night. The emulator uses NWS reporting location, no HiRad. Glad your enjoying the emulator! :)
Title: Re: Emulator Release - January 2009
Post by: LOT8MANIS on January 30, 2009, 11:19:59 AM
    Martin & Brian, I remember back around Thanksgiving I had requested a key to participate in the emulator, but apparently, it was you Brian who had told me the fact that the emulator was being updated; So I was only able to enjoy a trial version off of Martin's affiliate ID. Not too long after that I ended up uninstalling the emulator thus now I will have to reinstall it, so will one of you please give me a login & password now that a there's a new release out on the emulator? Thank you.
Title: Re: Emulator Release - January 2009
Post by: TWCToday on January 30, 2009, 03:46:35 PM
    Martin & Brian, I remember back around Thanksgiving I had requested a key to participate in the emulator, but apparently, it was you Brian who had told me the fact that the emulator was being updated; So I was only able to enjoy a trial version off of Martin's affiliate ID. Not too long after that I ended up uninstalling the emulator thus now I will have to reinstall it, so will one of you please give me a login & password now that a there's a new release out on the emulator? Thank you.
pm me with a username and password you want to use
Title: Re: Emulator Release - January 2009
Post by: Jonathan on January 30, 2009, 04:18:29 PM
Absolutely amazing, guys. :)
Title: Re: Emulator Release - January 2009
Post by: LOT8MANIS on February 01, 2009, 04:55:49 PM
Okay, was able to download the new setup file, installed it, and got my new key.  Then I realized I had to do the "unregister 1-2-3-OK" command, now when I go to run the emulator, it requests a key.  I click GET MY KEY, and it says a key was already assigned to me.  I copy the key, then enter it on the next screen, and it says my key is not valid.  Did I unregister my key?
    Brian & Martin, I'm having the same problem shadyjay had except when I attempt to get a new key, it gives me the same one I had. I tried using it again, and I'm getting that same invalid key error. Yes, this is on the same computer. Would one of you please help? Thank you.
Title: Re: Emulator Release - January 2009
Post by: TWCToday on February 01, 2009, 05:08:29 PM
Ill see if Brian can reset you key. If you "Run Manual Update" (if on vista as admin) it may or may not help you out. There was a minor update done to help with the key setup. Whats your username?
Title: Re: Emulator Release - January 2009
Post by: LOT8MANIS on February 01, 2009, 05:31:16 PM
The username is WdstkGA1.

EDIT: The system I'm using if you're wondering is Windows XP Service Pack 3.
Title: Re: Emulator Release - January 2009
Post by: curtjr4 on February 01, 2009, 08:45:14 PM
Hi, I've requested a key back about 2 months ago. I was wondering if I can get a key to get into CINE and an Affiliate ID? Thanks...
Title: Re: Emulator Release - January 2009
Post by: Drew Richards on February 05, 2009, 10:53:07 AM
Okay, was able to download the new setup file, installed it, and got my new key.  Then I realized I had to do the "unregister 1-2-3-OK" command, now when I go to run the emulator, it requests a key.  I click GET MY KEY, and it says a key was already assigned to me.  I copy the key, then enter it on the next screen, and it says my key is not valid.  Did I unregister my key?
I am now having the same problems after I installed the new version. I am on the same computer I originally had wsxl installed on. It is giving me the message that I already have an assigned key, then informs me my key is not valid. My login name is drew on the cins system. Please let me know if there is any other information I need to provide.
Title: Re: Emulator Release - January 2009
Post by: NGAWX on February 05, 2009, 01:20:19 PM
This sounds great! How can I go about getting a user name and password to download?
Title: Re: Emulator Release - January 2009
Post by: cc17926 on February 06, 2009, 11:48:09 AM
This sounds great! How can I go about getting a user name and password to download?

while i should set up a form for inquring users to setup an account.. in the mean time, forward to me a login and password and i will be able to help you out..
Title: Re: Emulator Release - January 2009
Post by: TWCToday on February 07, 2009, 03:32:14 PM
This sounds great! How can I go about getting a user name and password to download?
Sorry it took so long but your setup
Title: Re: Emulator Release - January 2009
Post by: NGAWX on February 07, 2009, 06:23:28 PM
Many Many thanks!  :thumbsup:
Title: Re: Emulator Release - January 2009
Post by: curtjr4 on February 13, 2009, 04:51:12 PM
May I somehow get an account so that I can use the emulator?

Thanks,
Curt
Title: Re: Emulator Release - January 2009
Post by: tuez13 on March 04, 2009, 04:54:58 PM
I was also hoping to get in on the fun with the emulator.  Is there a form that has been created for that?  Thanks in advance!
Title: Re: Emulator Release - January 2009
Post by: Lamarr on March 16, 2009, 07:44:45 PM
May I somehow get an account so that I can use the emulator?

Thanks,
Curt
Likewise.